]> git.jsancho.org Git - guile-assimp.git/blobdiff - src/Makefile.am
Sources Reorganization
[guile-assimp.git] / src / Makefile.am
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644 (file)
index 0000000..aa0c111
--- /dev/null
@@ -0,0 +1,35 @@
+## Process this file with automake to produce Makefile.in.
+##
+## guile-assimp, foreign interface to libassimp
+## Copyright (C) 2014 by Javier Sancho Fernandez <jsf at jsancho dot org>
+##
+## This program is free software: you can redistribute it and/or modify
+## it under the terms of the GNU General Public License as published by
+## the Free Software Foundation, either version 3 of the License, or
+## (at your option) any later version.
+##
+## This program is distributed in the hope that it will be useful,
+## but WITHOUT ANY WARRANTY; without even the implied warranty of
+## MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+## GNU General Public License for more details.
+##
+## You should have received a copy of the GNU General Public License
+## along with this program.  If not, see <http://www.gnu.org/licenses/>.
+
+include ../guile.am
+
+moddir=$(prefix)/share/guile/site/$(GUILE_EFFECTIVE_VERSION)
+godir=$(libdir)/guile/$(GUILE_EFFECTIVE_VERSION)/ccache
+
+SOURCES = \
+       assimp.scm \
+       assimp/low-level.scm \
+       assimp/low-level/cimport.scm \
+       assimp/low-level/color.scm \
+       assimp/low-level/material.scm \
+       assimp/low-level/matrix.scm \
+       assimp/low-level/mesh.scm \
+       assimp/low-level/postprocess.scm \
+       assimp/low-level/scene.scm \
+       assimp/low-level/types.scm \
+       assimp/low-level/vector.scm