Preparing version 1.0.1
[datasette-pytables.git] / setup.py
1 from setuptools import setup
2 import os
3
4 def get_version():
5     with open('VERSION') as fd:
6         return fd.read()
7
8 def get_long_description():
9     with open(os.path.join(
10         os.path.dirname(os.path.abspath(__file__)), 'README.md'
11     ), encoding='utf8') as fp:
12         return fp.read()
13
14
15 setup(
16     name='datasette-pytables',
17     version=get_version(),
18     description='Datasette connector for loading pytables files (.h5)',
19     long_description=get_long_description(),
20     long_description_content_type='text/markdown',
21     author='Javier Sancho',
22     url='https://github.com/jsancho-gpl/datasette-pytables',
23     license='Apache License, Version 2.0',
24     packages=['datasette_pytables'],
25     entry_points={
26         'datasette.connectors': [
27             'pytables = datasette_pytables'
28         ],
29     },
30     install_requires=['datasette-core', 'tables', 'moz-sql-parser', 'mo-future'],
31     tests_require=['pytest']
32 )
33