]> git.jsancho.org Git - lugaru.git/blob - libogg-1.0/libogg.spec
Quickly created CMake to build the source
[lugaru.git] / libogg-1.0 / libogg.spec
1 Name:           libogg
2 Version:        1.0
3 Release:        1
4 Summary:        Ogg Bitstream Library
5
6 Group:          System Environment/Libraries
7 License:        BSD
8 URL:            http://www.xiph.org/
9 Vendor:         Xiph.org Foundation <team@xiph.org>
10 Source:         http://www.xiph.org/pub/ogg/vorbis/download/%{name}-%{version}.tar.gz
11 Prefix:         %{_prefix}
12 BuildRoot:      %{_tmppath}/%{name}-%{version}-root
13 # We're forced to use an epoch since both Red Hat and Ximian use it in their
14 # rc packages
15 Epoch:          2
16 # Dirty trick to tell rpm that this package actually provides what the
17 # last rc and beta was offering
18 Provides:       %{name} = %{epoch}:1.0rc3-%{release}
19 Provides:       %{name} = %{epoch}:1.0beta4-%{release}
20
21 %description
22 Libogg is a library for manipulating ogg bitstreams.  It handles
23 both making ogg bitstreams and getting packets from ogg bitstreams.
24
25 %package devel
26 Summary:        Ogg Bitstream Library Development
27 Group:          Development/Libraries
28 Requires:       libogg = %{version}
29 # Dirty trick to tell rpm that this package actually provides what the
30 # last rc and beta was offering
31 Provides:       %{name}-devel = %{epoch}:1.0rc3-%{release}
32 Provides:       %{name}-devel = %{epoch}:1.0beta4-%{release}
33
34
35 %description devel
36 The libogg-devel package contains the header files, static libraries
37 and documentation needed to develop applications with libogg.
38
39 %prep
40 %setup -q -n %{name}-%{version}
41
42 %build
43 CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=%{_prefix} --enable-static
44 make
45
46 %install
47 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
48
49 make DESTDIR=$RPM_BUILD_ROOT install
50
51 %clean
52 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
53
54 %post
55 /sbin/ldconfig
56
57 %postun
58 /sbin/ldconfig
59
60 %files
61 %defattr(-,root,root)
62 %doc AUTHORS CHANGES COPYING README
63 %{_libdir}/libogg.so.*
64
65 %files devel
66 %defattr(-,root,root)
67 %doc doc/index.html
68 %doc doc/framing.html
69 %doc doc/oggstream.html
70 %doc doc/white-ogg.png
71 %doc doc/white-xifish.png
72 %doc doc/stream.png
73 %doc doc/ogg/*.html
74 %doc doc/ogg/style.css
75 %{_includedir}/ogg/ogg.h
76 %{_includedir}/ogg/os_types.h
77 %{_includedir}/ogg/config_types.h
78 %{_libdir}/libogg.a
79 %{_libdir}/libogg.so
80 %{_datadir}/aclocal/ogg.m4
81
82 %changelog
83 * Sun Jul 14 2002 Thomas Vander Stichele <thomas@apestaart.org>
84 - update for 1.0 release
85 - conform Group to Red Hat's idea of it
86 - take out case where configure doesn't exist; a tarball should have it
87
88 * Tue Dec 18 2001 Jack Moffitt <jack@xiph.org>
89 - Update for RC3 release
90
91 * Sun Oct 07 2001 Jack Moffitt <jack@xiph.org>
92 - add support for configurable prefixes
93
94 * Sat Sep 02 2000 Jack Moffitt <jack@icecast.org>
95 - initial spec file created